Home Page
RABiD BUNNY FEVER
K.T.K

  • September 20, 2017, 12:35:07 PM *
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

Official site launch very soon, hurrah!


Author Topic: Status Hot Keys  (Read 20608 times)

Dakusan

  • Programmer Person
  • Administrator
  • Hero Member
  • *****
  • Posts: 514
    • View Profile
    • WWW
Re: Status Hot Keys
« Reply #15 on: January 11, 2013, 05:12:29 PM »
I'm betting this is due to the GTK command key mappings being changed in a new version, or maybe on Windows 7.

This should theoretically be fixable by adding values in Config.c lines 179-181 to the ends of the GDKControlMasks, ControlMasks, and ControlKeyValues variables.

Add to the end of "GDKControlMasks" one of the values from: http://developer.gnome.org/gdk/stable/gdk-Windows.html#GdkModifierType
Add to the end of "ControlMasks" another "MODK_WIN"
Add to the end of "ControlKeyValues" 2 appropriate values from: http://docs.adacore.com/gtkada-docs/gtkada_rm/gtkada_rm/gdk-types-keysyms.ads.html (Maybe "GDK_Meta_L" and "GDK_Meta_R"?)

I'll have to get my development environment set back up to figure out what the values should be for me, and hopefully for you, and release a new version. Not sure when I'll get to this, but maybe soon. If you want to try to compile the code yourself you might be able to figure it out too.
Logged

Dakusan

  • Programmer Person
  • Administrator
  • Hero Member
  • *****
  • Posts: 514
    • View Profile
    • WWW
Re: Status Hot Keys
« Reply #16 on: January 15, 2013, 05:47:18 PM »
This is fixable by editing the preferences directly (See last part of this post), as this is just a problem with the configuration section.

I went ahead and got my development environment set up and the problem tested. Unfortunately, this looks like a problem with either our hardware (I am suspect since I am running on mac hardware w/ EFI), or GTK itself. GTK isn't detecting the windows key at all as a meta key (like shift, alt, or ctrl), so I would have to do some major changes in that section to program around this. A new version of GTK may have this fixed. This report looks like it may be promising.

So I'll have to experiment with newer versions of GTK later and see if these are compatible with pidgin to fix this...

I wouldn't hold your breath on this getting fixed any time soon though, sorry.

However, you can manually set your own keyboard shortcuts that will work directly with windows by editing your prefs.xml (C:\Users\USERNAME\AppData\Roaming\.purple\prefs.xml) WHEN PIDGIN IS CLOSED. Search for "<pref name='StatusHotKeys'>" and then edit the associated "Action#_Key" by adding 524288 to its number to add the win key. I have tested and confirmed this works.
« Last Edit: January 15, 2013, 05:49:40 PM by Dakusan »
Logged